Welcome, Guest
Username: Password: Remember me

TOPIC: Problem with double links

Problem with double links 4 years 5 months ago #1647

  • trish
  • trish's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Hi i have a problem with displaing the links of mega mini news module.
In settings i've shown to display module on all pages. But the links have a different path from each menu for examlpe:
hitreeworkers.ru/9-poslednie-sobytiya/51...stushchee-iz-kryshi/
____
and the same article showing when i'm clicking on (ex. "about company" page)but with the different link:
hitreeworkers.ru/o-kompanii/9-poslednie-...stushchee-iz-kryshi/
_______
I want to display as it showing in live demo.
i need to display all the news by static link only from main page, even when i clicking another page the path from news must be damainname.ru/category/item#1 (item#2 item#3, ect.)
___
How can i build it?

Thanks.

PS: sorry for my bad english i'm a Russian
The administrator has disabled public write access.

Re: Problem with double links 4 years 5 months ago #1654

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
Hi,
This is the Itemid problem - a common problem when you use Joomla!. One solution is add additional Itemid via parameters.
I want to display as it showing in live demo.
i need to display all the news by static link only from main page, even when i clicking another page the path from news must be damainname.ru/category/item#1 (item#2 item#3, ect.)

Very sorry that it depends on SEF of Joomla! or sef component. We just use JRoute of Joomla! core to build the links.

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
The administrator has disabled public write access.
The following user(s) said Thank You: trish

Re: Problem with double links 4 years 5 months ago #1660

  • trish
  • trish's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
I've fixed the problem.
in modules\mod_megamininews\tmpl\default.php instead
<a href="<?php echo $item->link; ?>"></a>
i've put these link:
<a href="<?php echo $item->category_alias,'/', $item->alias; ?>">
maybe it's wrong bur it works :cheer:
I've not inserted $id for categories and items because i've turn it off displaying id in url
The administrator has disabled public write access.
Time to create page: 0.165 seconds