normal Don't Expand Main Menu - Sub Menus

More
10 years 1 month ago #7184 by Kamil Churzepa
Hello,

Indeed, after installing a "clean" template top menu developing normally. However, after installing some additives based the javascript there is a problem (eg after installing "OT LightBox Login" or "YJ Pop Login", etc..)
The error is in the template.

What needs to be improved in the code (in template) to make the menu work properly with additives based on javacsript?

Regards.

Please Log in or Create an account to join the conversation.

More

Notice: Undefined variable: end_tag_params in /home/omegatheme/public_html/libraries/kunena/External/Nbbc/src/BBCode.php on line 2321

Notice: Undefined variable: end_tag_params in /home/omegatheme/public_html/libraries/kunena/External/Nbbc/src/BBCode.php on line 2321

Notice: Undefined variable: end_tag_params in /home/omegatheme/public_html/libraries/kunena/External/Nbbc/src/BBCode.php on line 2321
10 years 1 month ago #7217 by Trung Duong
Cause Mootool is core of javascript, so if your module loads it again (twice) then it will be conflicted. If you can send me your ftp so i can help you easier.

Regards

Support email: services(at)omegatheme(dot)com


Follow Us to keep updated!

[img


[img


[img]...[/img]

[img]...[/img]

[img]...[/img]

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7242 by Kamil Churzepa
Hello,

In order to verify the problem I installed additionally the following templates:

OT Artwork
Ot Jewelery
OT Photographer
OT Rubbyshop
OT Swatch

and Appendix - Module "OT LightBox Login".

For all of the above templates, there was no problem with the drop-down top menu (there was no conflict of OT LightBox Login). Each template to work properly.

Therefore, the error is in the template OT Awesome.

Please install "clean" template OT Awesome along with the addition of OT LightBox Login. Then please create a few menu items (including one drop-down menu item). You will find out that the error is in the template OT Awesome.

Waiting for a solution to the problem.

Regards

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7244 by Trung Duong
Hello,

As my posted reason cause it's conflicting mootools. All templete are loads mootools script and Lightbox login module load mootools script again, so you can disable it by edit file:

modules/mod_ot_lightboxlogin/tmpl/default.php and remove / comment this code below:
Code:
JHTML::_('behavior.mootools');

Regards

Support email: services(at)omegatheme(dot)com


Follow Us to keep updated!

[img


[img


[img]...[/img]

[img]...[/img]

[img]...[/img]

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7248 by Kamil Churzepa
Hello,

The error is in the template OT Awesome.
I wrote you that the other templates (eg. Artwork OT, OT jewelery, etc.) are working properly without any modifications in the modules. Only template OT Awesome does not want to work correctly.

On my website I used many additives based on javascript.
I'm not going to improve each additive (modules, plugins, etc.) separately when the problem is evidently in the template.

Please correct the error in the template OT Awesome.

Waiting for your reply.
Regards

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7262 by Trung Duong
Hello,

You can edit this file(templates\ot_awesome\lib\layout\tpl.function.php) and find this code:
Code:
JHTML::_('behavior.framework');

Then change to
Code:
JHTML::_('behavior.framework', true);

Regards

Support email: services(at)omegatheme(dot)com


Follow Us to keep updated!

[img


[img


[img]...[/img]

[img]...[/img]

[img]...[/img]

Please Log in or Create an account to join the conversation.

Time to create page: 0.286 seconds

About Growth

Innovative tech for eCommerce growth

Contact Info

Head: No. 3, 175/55 Lane, Lac Long Quan St., Nghia Do Ward, Cau Giay District, Hanoi City, Vietnam