Welcome, Guest
Username: Password: Remember me

TOPIC: Bootstrap Applications

Bootstrap Applications 6 months 1 day ago #8742

  • silkjazz
  • silkjazz's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Dear Omegathemes/Mr Trungdt,

Thank you for your free Jarvis Framework and starter template which I'm using with Joomla 3.5.1. I have tried some bootstrap samples with your template and they work as they should. However, the tooltip and popover applications don't work.

The basic application for the popover is first the html then the script:

<div class="container">
<h3>Popover Example</h3>
<a href="#" data-toggle="popover" title="Popover Header" data-content="Some content inside the popover">Toggle popover</a>
</div>
<script>
$(document).ready(function(){
    $('[data-toggle="popover"]').popover();   
});
</script>

And for the Tooltip

<div class="container">
<h3>Tooltip Example</h3>
<a href="#" data-toggle="tooltip" title="Hooray!">Hover over me</a>
</div>
<script>
$(document).ready(function(){
    $('[data-toggle="tooltip"]').tooltip();   
});</script>

Neither seem to function when input in to the content editor (JCE) I have other bootstrap samples with scripts that do work. Could you tell me if these particular bootstrap samples are able to function with Jarvis and the template?

Kind Regards

SJ
The administrator has disabled public write access.

Bootstrap Applications 6 months 1 day ago #8743

  • caselock
  • caselock's Avatar
  • OFFLINE
  • Administrator
  • Posts: 229
  • Thank you received: 25
  • Karma: 1
Hello, Thanks for using our template!

The Jarvis fw using "Bootstrap v3.3.4". and I think there will not be any problems when you use the function from the bootstrap.
Could you please explain your issue? or send url to site I 'll check issue in your site.

Regards,
Kien
The administrator has disabled public write access.

Bootstrap Applications 5 months 4 weeks ago #8744

  • silkjazz
  • silkjazz's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Hello Kien,

Thanks for your reply. As I’m using the localhost I’m unable to give you access to my site so here is an example of what I mean.

This image is of the saved script and html in the JCE editor HTML view:

This image is hidden for guests. Please log in or register to see it.


This image is of the saved script and html in the JCE editor Normal view:

This image is hidden for guests. Please log in or register to see it.


This image is in the result in the front end and when the link is clicked on nothing happens, except the web page scrolls to the top:

This image is hidden for guests. Please log in or register to see it.


Here is the sample of what the result should be, from the site w3schools.com, where I copied the code:

This image is hidden for guests. Please log in or register to see it.


All of the w3schools.com bootstrap samples I have tried with Jarvis and the starter template work as they should, except the tooltip and popover samples. I have noticed that bootstrap v3.2 is used with Jarvis and the starter template and not the latest 3.3.6, though this difference in versions has no effect on the function of the w3schools.com bootstrap samples I use (they are using 3.3.6 via a CDN link) because the samples from the w3schools.com work exactly the same way on my localhost site with the latest Jarvis and the starter template. What could be the problem? Hope you can help.

Kind Regards,

SJ
The administrator has disabled public write access.

Bootstrap Applications 5 months 4 weeks ago #8745

  • caselock
  • caselock's Avatar
  • OFFLINE
  • Administrator
  • Posts: 229
  • Thank you received: 25
  • Karma: 1
Could you please set None Editor on Global Configuration then try again.
I think editors have removed all js code you add. You can add it to the: Template Manager / your template / Addvanced Tab / Custom Javascript and add code js
The administrator has disabled public write access.

Bootstrap Applications 5 months 3 weeks ago #8757

  • silkjazz
  • silkjazz's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Hello Kien,

Thanks for your reply. I followed your instructions but this does not make any difference! As I wrote earlier in this thread, other bootstrap applications work with additional JavaScript code that are both input into the (JCE) editor. So I know the code is not stripped out when the input is saved. Also JCE has an option, which I use, to include JavaScript code in the editor as I have used some JavaScript code to display the Tabs and Pills bootstrap applications properly.

Could you test the Popover or Tooltip bootstrap applications on your developer system? I believe you will find a similar problem.

Kind Regards

SJ
The administrator has disabled public write access.

Bootstrap Applications 5 months 3 weeks ago #8759

  • caselock
  • caselock's Avatar
  • OFFLINE
  • Administrator
  • Posts: 229
  • Thank you received: 25
  • Karma: 1
Please check demo.omegatheme.com/joomla3/ot_geeman/in...ntent/single-article
The site demo using jarvis same bootstrap.
I still think it's because you did not properly add, please send an email to support information site: This email address is being protected from spambots. You need JavaScript enabled to view it. I'll check help
The administrator has disabled public write access.

Bootstrap Applications 5 months 2 weeks ago #8762

  • silkjazz
  • silkjazz's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 7
  • Karma: 0
Hello Kien,

Thanks for your reply and example for the Bootstrap popover. I had to look at the source code for the example article you provided and it appears that your code is slightly different from the standard Bootstrap popover code. For example, your code:
<script>
jQuery(document).ready(function($){
     $('[data-toggle="popover"]').popover();
});
<script>
And the standard Bootstrap code:
<script>
$(document).ready(function(){
    $('[data-toggle="popover"]').popover(); 
});
</script>

The difference is that you have used “jQuery” instead of “$” at the beginning of the first line of code and added “$” to the end of the first line. Hmmm… This appears unusual :unsure: but it does produce the required result! :cheer: However, when clicking on the link the page scrolls to the top of the page, as it does on your article demo page. Replacing href="javascript://" with href="#" seems to prevent the scrolling. Thank you for taking time to look into this matter and producing a solution.

A final note, could you say when the Jarvis framework will receive its next update with a revised version number and changelog?

Kind Regards,

SJ
The administrator has disabled public write access.
Time to create page: 0.170 seconds