Welcome, Guest
Username: Password: Remember me

TOPIC: Change READMORE to READ MORE in Slideshow

Change READMORE to READ MORE in Slideshow 4 years 5 months ago #1575

  • pvollherbst
  • pvollherbst's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 3
  • Karma: 0
I would like to change the text "READMORE" to "READ MORE" in the Slideshow.

I found the following code in helper.php
if($params->get('show_readmore')==1)
{
$item->readmore = '<a class="readmore" href = "' .$item->link. '" title="'.$item->title.'"> '.JText::_("READMORE"). ' </a>' ;
}
else
{
$item->readmore ='';
}

I can change "READMORE" to "MORE" or "CONTINUE" and it works, but I couldn't figure out a way to enter the space for "READ MORE" - can this be done - what is the syntax to do that?

Thanks.
The administrator has disabled public write access.

Re: Change READMORE to READ MORE in Slideshow 4 years 5 months ago #1577

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
You can change it in language file.
Edit en-GB.mod_megafeaturedarticleshow.ini in /language/en-GB/ (if Joomla! 1.5) or /modules/mod_megafeaturedarticleshow/languages/ (if Joomla! 2.5) and translate the string.

Edit or add this line into file:
Joomla 1.5:
READMORE = Read more
Joomla 2.5:
READMORE = "Read more"

Hope this help

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
Last Edit: 4 years 5 months ago by linh_omg.
The administrator has disabled public write access.

Re: Change READMORE to READ MORE in Slideshow 4 years 5 months ago #1579

  • pvollherbst
  • pvollherbst's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 3
  • Karma: 0
:( No, it didn't work - had the same effect as what I already tried - everything after the space was ignored.

So setting
READMORE = "READ MORE"

in the modules/mod_megafeaturedarticleshow/language/en-GB/en-GB.mod_megafeaturedarticleshow.ini file

resulted in "READ" being displayed in the slide show.

Is there some special character missing that would allow the space (and the word "MORE") to be read properly?

Also, ColorZilla tells me that the color in the little squares at the bottom of the slide show is #fd5808. (what you click on to advance a slide). I would like to change this, but can't find that color anywhere in any CSS file. I looked in these:
customs.css
menu.css
layout.css
template.css
typography.css
modules/mod_megafeaturearticleshow/css/layout.css

Where can I find the .CSS that will change the "square" color in the slide show? (The color of "READMORE" was originally #fd5806 - I found that in customs.css and was able to change it).

Thanks!!
The administrator has disabled public write access.

Re: Change READMORE to READ MORE in Slideshow 4 years 5 months ago #1581

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
Hi,
For the Read more proplem, please check the translation more carefully, as I said you can try in /language/en-GB/. If the translation get much time of you, you can edit /modules/mod_megafeaturedarticleshow/helper.php in this module folder and change:
$item->readmore = '<a class="readmore" href = "' .$item->link. '" title="'.$item->title.'"> '.JText::_("READMORE"). ' </a>' ;

to:
$item->readmore = '<a class="readmore" href = "' .$item->link. '" title="'.$item->title.'"> Read more </a>' ;


For the color (background image color) of the square navigation buttons of slideshow, you can find this in customs.css;
.mega_slideshow #slidenav a {
    background: url("../images/bullet1.jpg") no-repeat scroll left center transparent;
}
.mega_slideshow #slidenav a.activeSlide {
    background: url("../images/bullet1-hover.jpg") no-repeat scroll left center transparent;
}

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
The administrator has disabled public write access.

Re: Change READMORE to READ MORE in Slideshow 4 years 5 months ago #1591

  • pvollherbst
  • pvollherbst's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 3
  • Karma: 0
Here is the code in helper.php.
if($params->get('show_readmore')==1)
{
$item->readmore = '<a class="readmore" href = "' .$item->link. '" title="'.$item->title.'"> '.JText::_("READMORE"). ' </a>' ;
}
else
{
$item->readmore ='';
}

If I change "READMORE" to "READ MORE", only the word "READ" displays in the slideshow. But if I change it to "READ MOR", then "READ MOR" displays. Weird.

It turns out that some CSS code in template.css (p.readmore, width=80px) was limiting the width of this text - (it was limiting the width of the text in the slideshow as well as the text of "Read more" at the end of an article). Why the text got shortened to "READ", instead of just truncated to "READ MOR", I don't understand. But when I changed that width to 100px, it made "READ MORE" display in the slideshow, but it also (of course) made the blocks around "Read more:" in an article too wide.

So I left the width at 80 px in template.css, and went to customs.css, and added a line under p.readmore for width=100px, and now everything is fine.

Sorry for the long post - hope it helps someone else!
The administrator has disabled public write access.
The following user(s) said Thank You: linh_omg
Time to create page: 0.176 seconds