Welcome, Guest
Username: Password: Remember me

TOPIC: Virtuemart product page will not display main image, only thumbnail

Virtuemart product page will not display main image, only thumbnail 4 years 3 days ago #2381

When I go to the product page, there is just a large white square where the main product image should be. I have used firebug to determine that there is a php script telling it to "display: none" but I can't figure out why and where it is located! Any ideas? It seems like this might be a template override, but I'm not sure.

Thank you!
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 4 years 2 days ago #2391

  • trungdt
  • trungdt's Avatar
  • OFFLINE
  • Administrator
  • Posts: 2287
  • Thank you received: 997
  • Karma: 121
Can you show me your screenshot with description ?
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2420

Sure, here is a screenshot with firebug open showing the "display: none" class and a large white box where the main image should be.
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2422

I also have encountered another display issue on the VirtueMart Products Scrollable module. It is throwing up a PHP script error that says: "Warning: Division by zero in /home/adaircct/public_html/templates/ot_swatch/html/mod_virtuemart_product/single.php on line 174"

When i turn error reporting off it simply shows a message "up to 0% off" in the product listings in the module.
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2440

Looks like I found the php line in default_images.php which commented out display of the main image. I removed the comment and it shows up. The problem now is that the image is not displayed in the proper size. What is the resizing script I need to add to make the main image fit in the main image box? Thanks!
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2441

  • trungdt
  • trungdt's Avatar
  • OFFLINE
  • Administrator
  • Posts: 2287
  • Thank you received: 997
  • Karma: 121
You can change thumbnails size in virtumart configuration without Enable Dynamic Thumbnail Resizing

Regards
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2647

This is not working for me. The main image is not staying within the container size. Shouldn't it be resized to fit the container size in product details page?

I have attached a screenshot.
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2670

  • trungdt
  • trungdt's Avatar
  • OFFLINE
  • Administrator
  • Posts: 2287
  • Thank you received: 997
  • Karma: 121
Can you submit your site URL here ?

Regards
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2747

THe site is www.adaircctv.com

I have had all kinds of problems making the product details page look right. Now it looks perfect in all browsers except internet explorer. I'm getting a red X where the images should be. Why is this and how do I fix it??

Thanks
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 11 months ago #2749

  • trungdt
  • trungdt's Avatar
  • OFFLINE
  • Administrator
  • Posts: 2287
  • Thank you received: 997
  • Karma: 121
Hello,

Because when image doesn't loaded with IE then you will have RED X in image.

Regards
The administrator has disabled public write access.

Re: Virtuemart product page will not display main image, only thumbnail 3 years 2 months ago #5235

  • makanp
  • makanp's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hi, please let me know if you managed to fix the issue with the red cross instead of an image. I am having the same issue with I.E.
Thanks
The administrator has disabled public write access.
Time to create page: 0.189 seconds