Welcome, Guest
Username: Password: Remember me

TOPIC: JUser: :_load: Unable to load user with ID: 62

JUser: :_load: Unable to load user with ID: 62 8 years 5 months ago #1428

  • clickandclick
  • clickandclick's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 51
  • Thank you received: 10
  • Karma: 0
Hi, in backend when i go to virtuemart component/shop it appears "JUser: :_load: Unable to load user with ID: 62" how can i get rid of it? i don't have any user with id 62.
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
Last Edit: 8 years 5 months ago by clickandclick.
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 5 months ago #1432

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
Hi,

We sometimes also get that error. When you go to Shop edit page, VirtueMart try to sync the user of Joomla! with VM user (62 ussually for Joomla! Administrator account) but for some reason (we create new user for admin and default 62 is removed for security; install from quickstart demo and new admin user id created but VM still remember old id, etc.).

A solution can be used:
Use phpMyAdmin or any mysql tool to change the user id from the record in table `PREFIX_virtuemart_vmusers` from 62 to the real number(your current admin user id) where PREFIX is depended on your installation.

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2128

  • erikken
  • erikken's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
i am getting this error
I created a new admin but the id is still 62
how do i get the proper id for the database table correct instead of 62
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2140

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
erikken wrote:
i am getting this error
I created a new admin but the id is still 62
how do i get the proper id for the database table correct instead of 62

Hi,
You can use phpMyAdmin to browse the database and in the SQL tab, paste this code and run:
UPDATE `PREFIX_virtuemart_vendors` SET `created_by`=0, `modified_by`=0;
UPDATE `PREFIX_virtuemart_categories` SET `created_by`=0, `modified_by`=0;
UPDATE `PREFIX_virtuemart_products` SET `created_by`=0, `modified_by`=0;

where PREFIX is your table prefix.

Then go to backend to retry.

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2145

  • erikken
  • erikken's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
after running the query with the prefix replaced with my actual database prefix the result was:

UPDATE `PREFIX_virtuemart_vendors` SET `created_by`=0, `modified_by`=0;# MySQL returned an empty result set (i.e. zero rows).

UPDATE `PREFIX_virtuemart_categories` SET `created_by`=0, `modified_by`=0;# MySQL returned an empty result set (i.e. zero rows).

UPDATE `PREFIX_virtuemart_products` SET `created_by`=0, `modified_by`=0;# MySQL returned an empty result set (i.e. zero rows).
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2146

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
Hi,
@erikken: Sorry, where did you get this error? Virtuemart or K2 or fontend homepage?
If not Virtuemart, run this:
UPDATE `PREFIX_k2_items` SET `created_by`=0, `modified_by`=0

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
Last Edit: 8 years 3 months ago by linh_omg.
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2151

  • erikken
  • erikken's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
whenever i go into virtuemart shop section in the back end of the page
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
Last Edit: 8 years 3 months ago by erikken.
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2152

  • linh_omg
  • linh_omg's Avatar
  • OFFLINE
  • Moderator
  • Posts: 910
  • Thank you received: 568
  • Karma: 25
Hi,
So you can try do more as this:
UPDATE `PREFIX_virtuemart_vmusers` SET `virtuemart_user_id`=YOUR_NEW_ADMIN_ID,`created_by`=0, `modified_by`=0;

Thanks
If you need to send us FTP access / host access, administrator access or any private information:
services(at)omegatheme(dot)com or drop a ticket www.omegatheme.com/member/
The administrator has disabled public write access.

Re: JUser: :_load: Unable to load user with ID: 62 8 years 3 months ago #2154

  • erikken
  • erikken's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 1
  • Karma: 0
Hello
that did not work either
I got rid of the error message by creating a whole bunch of users until one was assigned to the ID 62
thanks for your assistance
The administrator has disabled public write access.
Time to create page: 0.185 seconds