Welcome, Guest
Username: Password: Remember me

TOPIC: Error message after installation on website

Error message after installation on website 7 years 1 month ago #7077

  • samsunny
  • samsunny's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Strict Standards: Declaration of JParameter::loadSetupFile() should be compatible with that of JRegistry::loadSetupFile() in C:\xampp\htdocs\worksavvy\libraries\joomla\html\parameter.php on line 512

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\mod_ot_scroller.php on line 14

Strict Standards: Non-static method modOTScrollerHelper::getFolder() should not be called statically in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\mod_ot_scroller.php on line 19

Strict Standards: Non-static method modOTScrollerHelper::getImages() should not be called statically in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\mod_ot_scroller.php on line 20

Strict Standards: Creating default object from empty value in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\helper.php on line 40

Strict Standards: Creating default object from empty value in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\helper.php on line 40

Strict Standards: Creating default object from empty value in C:\xampp\htdocs\worksavvy\modules\mod_ot_scroller\helper.php on line 40

How do I fix this?
The administrator has disabled public write access.

Re: Error message after installation on website 7 years 1 month ago #7086

  • trungdt
  • trungdt's Avatar
  • OFFLINE
  • Administrator
  • Posts: 2284
  • Thank you received: 998
  • Karma: 121
Hello,

Note your PHP configuration is set to display errors whereas these should be off for an ideal installation/server particularly one that is live.
Locate the php.ini file and the line
 display_errors = On
and change this to
display_errors = Off
At the same time you should also do the same for
magic_quotes_gpc = On
and change to
magic_quotes_gpc = Off

and edit this file: libraries\joomla\html\parameter.php on line 512
public function loadSetupFile($path)

must be
public function loadSetupFile($path=null)

Regards
The administrator has disabled public write access.
Time to create page: 0.162 seconds